DELL N3000 User Manual

Page of 1460
756
Configuring the Spanning Tree Protocol
RSTP-PV Access Switch Configuration Example
In this configuration, all 1G ports are presumed to be connected to host 
machines, and the two 10G uplink ports are connected to an aggregation-
layer switch with a total L2 network diameter of 4. The aggregation-layer 
switch can be a single switch or multiple switches, running either RSTP-PV or 
MSTP. For fastest convergence during failover scenarios, it is recommended 
that the uplink switches be configured in RSTP-PV mode.
Three VLANs are configured in addition to VLAN 1. Te1/0/1 is configured to 
be the primary uplink port and Te1/0/2 is configured to be the backup uplink.
Configure VLANs 2 through 4 and return to Global Config mode.
console#configure
console(config)#vlan 2-4
console(config-vlan2-4)#exit
Enable RSTP-PV.
console(config)#spanning-tree mode rapid-pvst
Configure for a maximum network diameter of 4.
console(config)#spanning-tree vlan 1-4 max-age 16
Configure access and trunk ports
console(config)#interface range gi1/0/1-48
console(config-if)#switchport mode access
console(config-if)exit
console(config)#interface range te1/0/1-2
console(config-if)#switchport mode trunk
console(config-if)#exit
Configure interface te1/0/1 as the preferred uplink.
console(config)#interface te1/0/1
console(config-if)#spanning-tree port-priority 112
console(config-if)#exit
Assign ports to VLANs.
console(config)#interface range gi1/0/1-12
console(config-if)#switchport access vlan 1
console(config-if)#exit
console(config)#interface range gi1/0/1-12
console(config-if)#switchport access vlan 2
downloadlike
ArtboardArtboardArtboard
Report Bug